Resolved
Pushed an update which will now make payments immediately show up without the ~3min delay.
We will keep monitoring to see if the issue has been properly resolved.
Investigating
We are in active contact with the Flutterwave team, Issues have been going on since September 25th.
There is little we can do on our end but we will try to make some upgrades to a higher version of Flutterwave to see if that might be a possible solution.
Investigating
Payments in RWF don't seem to be getting properly processed